Cannot install and start Samba on Debian 8

After executing the install command bellow :

root@backup:/etc# apt-get install samba

I got this error message:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  bind9 bind9utils ctdb ldb-tools ntp smbldap-tools winbind
The following NEW packages will be installed:
  samba
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/1,031 kB of archives.
After this operation, 11.7 MB of additional disk space will be used.
Selecting previously unselected package samba.
(Reading database ... 64944 files and directories currently installed.)
Preparing to unpack .../samba_2%3a4.2.14+dfsg-0+deb8u9_amd64.deb ...
Unpacking samba (2:4.2.14+dfsg-0+deb8u9) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for systemd (215-17+deb8u7) ...
Setting up samba (2:4.2.14+dfsg-0+deb8u9) ...
insserv: warning: script 'S17hpessad' missing LSB tags and overrides
insserv: warning: script 'hpessad' missing LSB tags and overrides
Job for smbd.service failed. See 'systemctl status smbd.service' and 'journalctl -xn' for details.
invoke-rc.d: initscript smbd, action "start" failed.
dpkg: error processing package samba (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for systemd (215-17+deb8u7) ...
Errors were encountered while processing:
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)

to solve this issue, i had to purge samba and all its dependencies, then reinstall it.

root@backup:/etc# apt-get remove samba --purge
root@backup:/etc# apt-get autoremove --purge
root@backup:/etc# apt-get install samba

How useful was this post?

Average rating / 5. Vote count:

No votes so far! Be the first to rate this post.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.