www.numberspeaks.com

BLOG

Whitelist / Blacklist Amavis SpamAssassin Zimbra 8.6

Sometimes SpamAssassin scores email as False Positive spam, to avoid incoming emails to get junked, we can define globally in the config file /opt/zimbra/conf/amavisd.conf.in domain with a initial score. To whitelist a domain we add domain with a negative score: To blacklist a domain we add domain with positive score: To apply the modification restart Amavis: Now from the source of incoming emails we can see when it’s coming from mydomain.com the initial score is -3 and spammer.com is 5.

Fail2ban doesn’t ban but regex works

One of my Debian server with fail2ban has a problem to ban ip from brute force attack, however testing logs with fail2ban-regex worked perfectly. My solution has been found through this page. The cause of my issue was related to the timezone of the system. To solve this problem, i used the command bellow to reconfigure timezone and then fail2ban started to ban as usual.

GMMK Pro – The Ultimate Modular Mechanical Keyboard

In today’s world, a keyboard is much more than just an input device. It’s an extension of your personality and an essential tool that helps you perform your daily tasks. With the Glorious GMMK Pro, you can take your typing experience to the next level. This keyboard is designed for gamers and professionals who want to get the best out of their typing and gaming sessions. In this article, we’ll take a closer look at the features that make the Glorious GMMK Pro a must-have for anyone who takes their typing and gaming seriously. Modular DesignThe Glorious GMMK Pro is …

How to protect Odoo against brute force attack behind Nginx or Caddy

Odoo community is not protected against brute force attack by default, the system is vulnerable over internet, however Odoo store provides auth_brute_force App which can handle this task, it’s available through this link. But it doesn’t work correctly behind a reverse proxy such as Caddy or Nginx. In the second part of this post, i’ll explain the little tip to make it work. Download and install the module Download the file corresponding to your version of Odoo. Unzip the file “auth_brute_force-9.0.1.1.0.zip”. Move the folder “auth_brute_force” to your module folder: “/usr/lib/python2.7/dist-packages/openerp/addons/“. Enable the developper mode through “About” popup. Then go to …