www.numberspeaks.com

BLOG

Geektool : Display system information on your MacOS X desktop

If you would like to display system information on your desktop of your Mac OS X, Geektool is the right utility you need. First download and install geektool : https://www.tynsoe.org/v2/geektool/ Open geektool app. Drag and drop Shell on your desktop, and click on command button Paste this code bellow to display your local ip and public ip. But you will need to replace 192.168.101 by your network ip address. Result :

Add xlsx support in scheduled outgoing email – Odoo 11

Download updated report_xlsx module Report_xlsx module adds xlsx report support to Odoo with xlsxwriter python library. However when trying to send an email with a xlsx report attached. I got this error message: “Unsupported report type xlsx found”. Mail module handles only PDF document as attachement, to add xlsx type support, we have to make some modification on report_xlsx module by inheriting mail.template model and overriding generate_email method, you’ll find the code bellow, customized report_xlsx module is downloadable above or by clicking on the link at the bottom of the page. Updated report_xlsx module for Odoo 11 community is available …

Linux

Odoo 9 Linux bash backup script

Bash backup odoo script is available on GitHub for Odoo 8 and 11. This bash script will help you to backup Odoo database, set a password on the backup file and remove files older than 7 days. You’ll need curl and 7zip linux package to make it work. This example is backing up od11-01 and od11-02 databases. It’s not really optimized with the double compression. BACKUP_DIR=/opt/backup ODOO_DATABASES="od11-01 od11-02" ADMIN_PASSWORD="ODOO_DATABASE_MANAGER_PASSORD" FILE_PASSWORD="ZIP_FILE_PASSWORD" TIMESTAMP=`date +%Y-%m-%d_%H-%M-%S` for DB in ${ODOO_DATABASES} do # create a backup curl -X POST \ -F "master_pwd=${ADMIN_PASSWORD}" \ -F "name=${DB}" \ -F "backup_format=zip" \ -o ${BACKUP_DIR}/${DB}/${DB}.${TIMESTAMP}.zip \ http://localhost:8069/web/database/backup 7z a …

Add menu in dropdown list on tree view – Odoo 9

To add an additional menu in action dropdown list on tree view, we need to register “ir.actions.server” and “ir.values” on the qweb/xml file as follow. Note that code field name is using old Odoo python API. <?xml version="1.0" encoding="utf-8"?> <openerp> <data> … <record id="action_cancel_request" model="ir.actions.server"> <field name="name">Cancel</field> <field name="type">ir.actions.server</field> <field name="model_id" ref="sale.model_sale_order" /> <field name="state">code</field> <field name="binding_model_id" ref="sale.model_sale_order" /> <field name="code">action = self.action_cancel(cr, uid, context.get(‘active_ids’, []), context=context)</field> </record> <record id="cancel_action_menu" model="ir.values"> <field eval="’client_action_multi’" name="key2"/> <field eval="’sale.order’" name="model"/> <field name="name">Cancel</field> <field eval="’ir.actions.server,%d’%action_cancel_request" name="value"/> </record> …. </data> </openerp> In your sale order model create the method as bellow with Odoo new API. …

Mssql differential restoration error

After trying to restore differential backup after a full backup, i got this error message : The log or differential backup cannot be restored because no files are ready to roll forward. To be able to complete differential restoration, full backup needs to be restored with “WITH NORECOVERY” option as follow: RESTORE DATABASE numberspeaks FROM DISK = ‘D:\numberspeaks-full.bak’ WITH NORECOVERY RESTORE DATABASE numberspeaks FROM DISK = ‘D:\numberspeaks-diff.bak’ WITH RECOVERY

Fail2ban doesn’t ban but regex works

One of my Debian server with fail2ban has a problem to ban ip from brute force attack, however testing logs with fail2ban-regex worked perfectly. My solution has been found through this page. The cause of my issue was related to the timezone of the system. To solve this problem, i used the command bellow to reconfigure timezone and then fail2ban started to ban as usual. sudo dpkg-reconfigure tzdata