www.numberspeaks.com

BLOG

Problem with Godaddy VPS upgrade

I recently had a problem with Godaddy ubuntu 16.04 VPS, after updating and upgrading the system: SSH port wasn’t anymore reachable, it’s the only access we have to the server, however other services are working normally, so the system is still running. I tried many times to restart, call the support, but it didn’t solve the problem. The only solution was to destroy the server and rebuild it from scratch + restoration of backups. I’ve also tested the upgrade with a clean and freshly installed system, same issue occurred. If you’re running Ubuntu 16.04 VPS on Godaddy, Do not upgrade …

How to protect Odoo against brute force attack behind Nginx or Caddy

Odoo community is not protected against brute force attack by default, the system is vulnerable over internet, however Odoo store provides auth_brute_force App which can handle this task, it’s available through this link. But it doesn’t work correctly behind a reverse proxy such as Caddy or Nginx. In the second part of this post, i’ll explain the little tip to make it work. Download and install the module Download the file corresponding to your version of Odoo. Unzip the file “auth_brute_force-9.0.1.1.0.zip”. Move the folder “auth_brute_force” to your module folder: “/usr/lib/python2.7/dist-packages/openerp/addons/“. Enable the developper mode through “About” popup. Then go to …

Fail2ban doesn’t ban but regex works

One of my Debian server with fail2ban has a problem to ban ip from brute force attack, however testing logs with fail2ban-regex worked perfectly. My solution has been found through this page. The cause of my issue was related to the timezone of the system. To solve this problem, i used the command bellow to reconfigure timezone and then fail2ban started to ban as usual.

Ping – NS

Ping – NS Network tools Tools WhoisDomain information DigList DNS record TraceTrace IP addresses Scan NetworkCheck all devices in your network Download Mobile App

zimbra

DKIM Zimbra 8.6

DKIM is an email authentication method designed to detect email spoofing, for more detail : Wiki DKIM, i’m describing in this post how to enable it with Zimbra. Make sure your DKIM has been enabled in your mail server. Add DNS TXT record: 148ERADC-FCE5-11E6-AF44-005A1B26B745._domainkey IN TXT v=DKIM1; k=rsa;p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDg2uVLIssdfsfgu62+c7n0sxugzm8Lpr4A7o7veL4kIeifat2hD53P2KKQTV978HxBTQKrEFByLbG0WZuNracNJU9L5NOKtmYnE7ksxF9ODMKqFK+ltsmM9qkVxbU3xQOVdufDlV2Zk8Ya0WMkYWzKgWIwIDAQAB Test DKIM signature by sending email using this website: http://dkimvalidator.com/